DBSTalk Forum banner

On Demand question

1085 Views 3 Replies 3 Participants Last post by  [email protected] Network
When I select All TV channels, I get the following message:

This feature is available only if your receiver is connected to your broadband internet connection..."

It is connected. I was able to select Blockbuster @Home and select a movie to watch and it worked. Why isn't All TV channels working?

I went into settings and reset the broadband connect and it still will not work.
1 - 4 of 4 Posts
Are you doing this from a Hopper or a Joey?
You may just need to reset the broadband connection. Press Menu > Yellow > Blue, then select broadband and reset connection. If you are still not able to access All Channels under the On Demand menu, please send me a PM with your phone or account number so I can assist you further. Thanks!
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.