DBSTalk Forum banner
Status
Not open for further replies.
1 - 19 of 19 Posts

·
Mentor
Joined
·
48 Posts
Discussion Starter · #1 ·
I am getting no sound output from the HR20 to my harman/kardon avr 300 receiver. I know my sound receiver is okay, dvd plays great. I bought new optical cable cable today, thinking maybe my old one was damaged. Still no sound. After one hour of talking to DTV, they told me my cable had to specifically say for dolby digital. I will buy another cable, but want to make sure this is right. Has anyone else had a problem with no sound output? (sound is fine through the audio on the tv - audio cable hookup. Any help greatly appreciated.
 

·
Legend
Joined
·
206 Posts
Not sure about your specific receiver but I think I had to go into my receiver menu and assign the proper cabling to the individual digital inputs. As an example when I switched from HDMI to Optical, I had manually change that in the receiver menu for it to work. Your receiver manual might have instructions.
 

·
Legend
Joined
·
125 Posts
kenmoo said:
Not sure about your specific receiver but I think I had to go into my receiver menu and assign the proper cabling to the individual digital inputs. As an example when I switched from HDMI to Optical, I had manually change that in the receiver menu for it to work. Your receiver manual might have instructions.
Cable does not have to say DD on it. But I agree with the above statement, you have to go into your setup menu in the HK and make sure the correct optical input is assigned, your AVR is probably looking for the Analog hookup from the HR20.
 

·
Mentor
Joined
·
48 Posts
Discussion Starter · #4 ·
Staszek said:
Cable does not have to say DD on it. But I agree with the above statement, you have to go into your setup menu in the HK and make sure the correct optical input is assigned, your AVR is probably looking for the Analog hookup from the HR20.
I am no wizard, but it was working fine with my old tivo receiver. Nothing changed except the directv receiver.
 

·
Godfather
Joined
·
690 Posts
Staszek said:
Cable does not have to say DD on it. But I agree with the above statement, you have to go into your setup menu in the HK and make sure the correct optical input is assigned, your AVR is probably looking for the Analog hookup from the HR20.
Yes, I agree. You do have to adjust your receiver's settings.
 

·
Hall Of Fame
Joined
·
1,765 Posts
I had this problem with my DVD player. My amp has only one Optical and One COAX input. For some reason though i have switched these form one dVD player to another and gotten no sound at all. Assigning the input in the menu of the amp has produced the sound I was expecting. Even if you had sound befroe it would be good to go in an confirm that the correct input is assigned to the right cable.

As a test if you have another device hooked up though Optical tune to it and then change the cable from that device to the HR20 and see if you get sound.
 

·
Mentor
Joined
·
38 Posts
Marwood said:
After one hour of talking to DTV, they told me my cable had to specifically say for dolby digital. I will buy another cable, but want to make sure this is right.
Fiber is Fiber. ( unless it is POF for IDB1394, but that will eventually be in your car ;) )

Seriously, save your $. This is probably the #1 reason I can't stand talking to CSRs at times. You may want to save the reciept and packaging for the new one since it is likely not a problem with the line itself.

If the optical input is re-assignable, you may want to attempt re-assigning it to the input you are anticipating. Have you cycled through all of your inputs for S&G's?

By chance are you using an HDMI cable from the HR20 to the TV? I have wondered if the device sees and HDMI -> HDMI connection if it will actually send the audio signal to the HDMI cable and disable the fiber...
 

·
Registered
Joined
·
5,957 Posts
tejohnson said:
Fiber is Fiber. ( unless it is POF for IDB1394, but that will eventually be in your car ;) )

Seriously, save your $. This is probably the #1 reason I can't stand talking to CSRs at times. You may want to save the reciept and packaging for the new one since it is likely not a problem with the line itself.

If the optical input is re-assignable, you may want to attempt re-assigning it to the input you are anticipating. Have you cycled through all of your inputs for S&G's?

By chance are you using an HDMI cable from the HR20 to the TV? I have wondered if the device sees and HDMI -> HDMI connection if it will actually send the audio signal to the HDMI cable and disable the fiber...
I have both connected and and both work fine (HDMI and Optical) with my Onkyo Integra 7.1. I had to do nothing more than turn Dolby on in the HR20 and my display immediately showed DD 5.1 on HD-Net, and not on for MSNBC as I switched between them. This has worked since day 1, through all updates.
 

·
Mentor
Joined
·
38 Posts
Marwood said:
On my tivo box the optical input was lit up, there is no light on the HR20, is this normal?
I would say "probably not" since there does not seem to be a place to select between the optical or other outputs in the UI of the HR20. So if there is no way to switch, I would assume it is "always on", and a red glow should be coming out of the port.

hasan said:
I have both connected and and both work fine (HDMI and Optical) with my Onkyo Integra 7.1. I had to do nothing more than turn Dolby on in the HR20 and my display immediately showed DD 5.1 on HD-Net, and not on for MSNBC as I switched between them. This has worked since day 1, through all updates.
Interesting to know. I had been thinking of getting a different receiver with an HDMI passthrough since my Sony Wega only has one DVI input.
 

·
Mentor
Joined
·
48 Posts
Discussion Starter · #15 ·
I think that makes the most sense. I will call D* today, You would think that would be something they would ask me. Usually I know more then they do, and I don't know alot!
 

·
Registered
Joined
·
32,456 Posts
hasan said:
I have both connected and and both work fine (HDMI and Optical) with my Onkyo Integra 7.1. I had to do nothing more than turn Dolby on in the HR20 and my display immediately showed DD 5.1 on HD-Net, and not on for MSNBC as I switched between them. This has worked since day 1, through all updates.
I have the Onkyo 989, and had the exeaxt dame experience. I actually use the Optical and DVI connectivity, and never have any audio issues at all since day one.
Scott R. Scherr said:
I think the optical port on your HR20-700 is dead. Mine died and D* shipped me a new box which also had a dead port. I rehooked up my HR10-250 and the optical connection worked fine.

Scott
Be aware that optical cables are among the most "touchy" of all connections - I always have 1-2 spares to check out if its the cable or something else....check your cable first either on another piece of equipment or else use another cable first, before concluding its the box. With Monoprice.com prices on these things, its easy to have spares around...
 

·
Legend
Joined
·
125 Posts
Scott R. Scherr said:
I think the optical port on your HR20-700 is dead. Mine died and D* shipped me a new box which also had a dead port. I rehooked up my HR10-250 and the optical connection worked fine.

Scott
Yea I should have asked that earlier, because mine is lit up even though I am not using it. It should be lit all the time
 

·
Mentor
Joined
·
48 Posts
Discussion Starter · #18 ·
I just got off the phone with dtv. The csr kept telling me that sometimes they light up and sometimes they don't! I know this is wrong. Anyway, I inisted on a way to test the optical output - and suddenly they are sending a replacement! They said it would be reconditioned - should I worry about that - I just paid for a new one!
 

·
AllStar
Joined
·
64 Posts
Thanks for the tips, everyone. My optical port does not light up on my current receiver or the replacement. As I mentioned, I hooked my HR10-250 and dolby digital and the same optical cable worked fine, I tried a second optical cable and it worked with my DVD player, but not with the HR20-700.

I think I have a dead port on both. A replacement is on the way.

Scott
 
1 - 19 of 19 Posts
Status
Not open for further replies.
Top