DBSTalk Forum banner
1 - 4 of 4 Posts

· Mentor
Joined
·
35 Posts
Discussion Starter · #1 ·
I just finished up a big Sports Bar custom install with 14 HD receivers using a slimline 5 lnb dish and Zinwell 16 port multi-switch and 14 HD receivers. I have been having problems with random receivers loosing signal all together. The funny part about it is that I can connect up to 13 receivers and everything is fine. Once I hook up a 14th receiver one of the receivers will drop out. Its random and not always the same port though. I at first thought maybe its a bad cable or cable end but If I move the cables around from port to port its not the same receiver that fails.
I am going back tomorrow with a new multi-switch but thought I would ask if anyone else has seen this problem problem before.
 

· Godfather
Joined
·
499 Posts
Swapping out the multiswitch seems the best approach to determine quickly if it the MS or one of the receivers causing some kind of electrical/signal overload or interference that the switch can't handle.
 

· Hall Of Fame
Joined
·
8,968 Posts
One possibility is that you have a bad ground at an outlet that powers one of the receivers. Connecting that receiver in can cause a ground loop.
 

· Mentor
Joined
·
35 Posts
Discussion Starter · #4 ·
I swapped out the Multi-switch and and also carefully inspected every coax connection for possible small frey or shorted ground to center conductor. I did see a couple of questionable connections so I cut them off and installed new ends.
After installation of the new switch everything is working fine. I am still not absolutely sure the multi-switch was the problem or a possible connector but it works now.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top