DBSTalk Forum banner
Not open for further replies.
1 - 5 of 5 Posts

· Godfather
352 Posts
Discussion Starter · #1 ·
Thought I would share my Sling performance fix.

Issue: frequent buffering when watching my DVR remotely.

My ISP is a 40mg/5mg so I did not think that was my issue. HD channels would continually buffer and SD did to, but not as much.

The bottleneck was my router. After testing multiple settings and options, I found that if I enable the QoS (Quality of Service) option for my Hopper/Sling and set the option to HIGH, zero buffering when watching remotely.

I also tested this with a spare router (reset to default,) and removed all my other network connected items and it worked fine without the Qos enabled.
Depending on your ISP, you may be able to connect your DVR/Sling directly to the cable/dsl modem to test this too. As long as your DVR gets an IP address, it should work. This would be the quickest way to test.

So this tells me that all my network toys are flooding my router and the QoS option will set the filter/priority for my Sling to high. QoS just gives my Sling priority over other network request. I'v seen no changes in my VOIP or other internet connected devices.

So if your seeing frequent buffering and you have a bunch of internet toys connected to your router, see if my fix will help.

· Icon
643 Posts
Yes, too many toys.... wish there was a good source for "optimum router settings for beginners" manual.

Linksys WRT54G
to Hopper
to 2 PC's
to Linksys PAP2 for Viatalk VOIP
wifi to Wii
wifi to Panasonic Vierra
wifi to any phone/tablet that happens to be on
Any better router suggestions?

Fortunately not many problems, but have no clue what ideal settings should be. Biggest problems are with VOIP, but not major (one way audio occasionally). I found the biggest problem with Hopper was buffering a rented show... letting it download completely seems to solve that issue. Dish Remote DVR access seems to either work or not work (Dish, not router).
1 - 5 of 5 Posts
Not open for further replies.